How to use the main window of the program, on which you can examine charts, construct routes, view weather, and see GPS position information.

The main window shows a chart and route information.  By default, the chart is the GSHHG planning chart.

Mode Buttons

The four left-side radio buttons specify the current operation mode on the chart.  You are either moving around the chart with left mouse clicks, zooming with left clicks, estimating distance and heading between points with left clicks, or adding and moving route points with left clicks.

Map Mode

Zoom Mode

Distance Mode

Edit Mode

All Modes


Zoom Shortcut Buttons

Route: zoom to show all visible routes.
Grib  zoom to show all visible Grib data.
Chart:  zoom to show the entire current chart.


Zoom Dropdown Box

With Mercator projection, sets width of main window in degrees.  With Equidistant or Plate Carree, sets height of main window in degrees.


GriB Periods Dropdown Box

GriB files normally contain forecast sequences: weather forecasts for a series of increasing times in the future.  Each time is called a forecast period.  The “Grib Periods” box contains the list of available forecast times.  Select a time to display forecast data for that period.  The keyboard up and down arrows provide a shortcut to move you up and down the list.  For example, if the selected date-time is “2010-01-01 1200Z”, then for each weather parameter (e.g., wind or pressure), the data for the forecast period starting at January 1, 2010 at 12Z is displayed. 

When multiple GriB files are loaded, the GriB Periods list contains the union of all forecast times in all GriB records.  It is possible that some forecast sequences will not contain forecasts at the precise time selected in the Grib Periods box.  In this case, the forecast period that contains the selected time is used.  If there is no such forecast period, no data is displayed. 

To override this automatic behavior, use the Grib Manager.  You can choose a specific forecast period for each weather sequence.  The data for this period will be displayed regardless of what is going on with the Grib Periods box.

As you cycle through periods in the Grib Periods box, any route point whose arrival time falls within the selected period will be highlighted with a green box.  This allows you to see where the boat will be along the route during that time period.


Undo and Redo Functions

You can undo and redo edits to routes and marks using the undo and redo commands available in the Tools menu.  The keyboard shortcut for undo is Ctrl-Z and the shortcut for redo is Ctrl-Y.  Note that undo and redo are not applicable to retime events that occur when you load a new wind Grib.


Autosaving

If the current race has been modified, an asterix is shown to the left of the race file name in the bottom left corner of the window.  Modified races are autosaved every minute to a file of the form #filename#.gpx, where filename is the name of your race file.  If you have selected “New” from the “File” menu, there is no associated race file until you attempt to save.  This situation is indicated by the word “Scratchpad” in the lower right hand corner.  Changes to the scratchpad race are always autosaved to the same file: #AUTOSAVE#.gpx.

You can change the autosave frequency from the General tab of the preferences window, Tools→Preferences".   The value should be decimal minutes between autosaves.